Menus
This article concerns the
macOS
app.
See other variants:
Windows

Note that this section only covers Texpad-specific menu items that have not been covered above. The usual Mac OS menu items behave as expected.

The Texpad Menu

Menu Option Explanation
Texpad About Texpad Information, legal statement and credits.
Texpad Texpad for iPad/iPod/iPhone A link to the iOS version of Texpad.
Texpad Preferences (Cmd- ,) Settings and preferences window.
Texpad Add/Edit Autocompleted Commands… Opens the directory where auto-complete commands can be customised.

The File Menu

Menu Option Explanation
File New From Template Create a new .tex document from a template.
File Add/Edit templates… View the directory where the templates are stored ~/Library/Application Support/Texpad/Templates/. Any files added to this directory are automatically listed in the File New From Template menu by Texpad.
File Reveal PDF in Finder (Cmd- R) Opens the Mac OS Finder where the output PDF file is stored.
[MENU]File,Email PDF (Cmd- E) Open a new email message with the current PDF file as an attachment.
File File Encoding Choose the file encoding Texpad should use for loading and saving files. If you alter the file encoding with open documents, Texpad will migrate all files in the project, and save to disc. We strongly recommend that you use UTF-8 file encoding for your work; it supports all languages, and as such it is becoming a de facto standard for plain text files.

[IMG]{200px}macos/encodings-menu]
File Reload with File Encoding If you see strange characters, there is a good chance you have opened a file with the incorrect encoding; this option will discard all changes and reload all open files using the specified character encoding.
File Print LaTeX Source… (Alt-Cmd- P) Prints the source code.
File Print PDF… (Cmd- P) Prints the PDF.

The Edit Menu

Menu Option Explanation
Edit Comment Block (Cmd- ]) and Edit Uncomment Block (Cmd- [) These menu options will comment or uncomment an entire block of text in one go.
Edit Indent Block (Shift-Cmd- ]) and Edit Unindent Block (Shift-Cmd- [) These menu options will indent or unindent an entire block of text.
Edit Autocomplete Force-opens the auto-complete window in the editor for the currently typed word. It is a menu alternative for the simple - Esc key.
Edit Global Search (Shift-Cmd- F) Brings into focus the global search field on the top of the window.

The Snippets Menu

The menu lists all the currently deployed snippets in the snippets’ directory that may be opened by selecting Add/Edit Snippets….

macos/snippets-menu.png

The Typeset Menu

See the help article on the Texpad Toolbar for details on various typesetters and their use.

Menu Option Explanation
Typeset Normal (Cmd- T) Normal typeset.
Typeset BibTeX (Cmd- B) Typeset and compile the bibliography file.
[MENU]Typeset,Add/Edit Global .tpbuild Scripts Opens directory BuildScripts containing all currently installed global .tpbuild scripts.
Typeset Toggle Auto-typeset (Shift-Cmd- L) Switches on and off the auto-typeset for the current project.
Typeset Remove Intermediate Files (Cmd- K) If the Hide intermediate files option is selected, Texpad keeps your home file uncluttered by hiding the intermediate files such as .aux, .log, etc. in a hidden directory called .texpadtmp. Selecting this menu option deletes this hidden directory. Note that this is safe operation and is sometimes necessary to remove possibly corrupted .aux files.
Typeset Abort Typesetting (Cmd- .) This will abort typesetting if in progress.

The Window Menu

Menu Option Explanation
Window Zoom In (Cmd- +) & Zoom Out (Cmd- -) Zoom in/out for the PDF pane.
Window Show Welcome Window (Ctrl-Cmd- T) Displays the Texpad welcome window.
Window Toggle Outline (Cmd- 1) Shows/hide the Outline View.
Window Hiding/showing View Panes (Cmd- 2 to Cmd- 4) Menu items to change arrangement of the editor between Editor only, Editor and Output, and Output only respectively.
Window Switch between PDF and Log Output (Cmd- 8 & Cmd- 9) Allows you to switch the output pane between the PDF view and the Error log.